fixed RAP build issues
authorVictor Kirhenshtein <victor@netxms.org>
Mon, 13 Nov 2017 13:38:32 +0000 (15:38 +0200)
committerVictor Kirhenshtein <victor@netxms.org>
Mon, 13 Nov 2017 13:44:18 +0000 (15:44 +0200)
32 files changed:
.gitignore
src/client/java/META-INF/MANIFEST.MF
src/java/netxms-eclipse/Core/META-INF/MANIFEST.MF
src/java/netxms-eclipse/EventManager/META-INF/MANIFEST.MF
src/libnxjava/java/base/.classpath
src/libnxjava/java/base/META-INF/MANIFEST.MF
webui/webapp/ActionManager/.settings/org.eclipse.jdt.core.prefs [new file with mode: 0644]
webui/webapp/ActionManager/META-INF/MANIFEST.MF
webui/webapp/ActionManager/src/org/netxms/ui/eclipse/actionmanager/dialogs/ActionSelectionDialog.java
webui/webapp/AgentManager/META-INF/MANIFEST.MF
webui/webapp/AlarmViewer/.settings/org.eclipse.jdt.core.prefs [new file with mode: 0644]
webui/webapp/AlarmViewer/META-INF/MANIFEST.MF
webui/webapp/AlarmViewer/src/org/netxms/ui/eclipse/alarmviewer/views/AlarmLogViewer.java
webui/webapp/Charts/META-INF/MANIFEST.MF
webui/webapp/Core/META-INF/MANIFEST.MF
webui/webapp/Dashboard/META-INF/MANIFEST.MF
webui/webapp/DataCollection/META-INF/MANIFEST.MF
webui/webapp/EPP/META-INF/MANIFEST.MF
webui/webapp/EventManager/META-INF/MANIFEST.MF
webui/webapp/FileManager/META-INF/MANIFEST.MF
webui/webapp/ImageLibrary/META-INF/MANIFEST.MF
webui/webapp/NetworkMaps/META-INF/MANIFEST.MF
webui/webapp/OSM/META-INF/MANIFEST.MF
webui/webapp/ObjectBrowser/META-INF/MANIFEST.MF
webui/webapp/ObjectManager/META-INF/MANIFEST.MF
webui/webapp/ObjectView/META-INF/MANIFEST.MF
webui/webapp/PerfView/META-INF/MANIFEST.MF
webui/webapp/PolicyManager/META-INF/MANIFEST.MF
webui/webapp/Reporter/META-INF/MANIFEST.MF
webui/webapp/ServerConfig/META-INF/MANIFEST.MF
webui/webapp/ServerJobManager/META-INF/MANIFEST.MF
webui/webapp/Topology/META-INF/MANIFEST.MF

index d989d4d..d276540 100644 (file)
@@ -183,9 +183,12 @@ target
 /src/java/nxreporting/src/main/resources/nxreporting.xml
 /src/libexpat/libexpat/x64
 /src/libnetxms/x64
-/src/libnxjava/java/.classpath
-/src/libnxjava/java/.project
-/src/libnxjava/java/.settings
+/src/libnxjava/java/base/netxms-base/.classpath
+/src/libnxjava/java/base/netxms-base/.project
+/src/libnxjava/java/base/netxms-base/.settings
+/src/libnxjava/java/bridge/.classpath
+/src/libnxjava/java/bridge/.project
+/src/libnxjava/java/bridge/.settings
 /src/libnxsl/lex.parser.cpp
 /src/libnxsl/lex.yy.cpp
 /src/libnxsl/parser.output
index ebfff07..744ca80 100644 (file)
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: Client Library API plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.clientlibrary;singleton:=true
-Bundle-Version: 2.1.6
+Bundle-Version: 2.2.0
 Bundle-Vendor: netxms.org
 Bundle-RequiredExecutionEnvironment: JavaSE-1.7
 Bundle-ClassPath: .
@@ -31,7 +31,7 @@ Export-Package: org.netxms.client,
  org.netxms.client.users,
  org.netxms.client.xml
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
- org.netxms.ui.base;bundle-version="2.1.2"
+ org.netxms.ui.base;bundle-version="2.2.0"
 Bundle-ActivationPolicy: lazy
 Bundle-Activator: org.netxms.client.plugin.Activator
 Import-Package: org.netxms.client.events
index 3dde1e6..79efa10 100644 (file)
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.netxms.ui.eclipse.console;singleton:=true
-Bundle-Version: 2.1.5
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.console.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.ui;bundle-version="[3.8.2,4.0.0)",
@@ -12,10 +12,10 @@ Require-Bundle: org.eclipse.ui;bundle-version="[3.8.2,4.0.0)",
  org.eclipse.ui.forms;bundle-version="3.5.200",
  org.eclipse.ui.console;bundle-version="3.5.100",
  org.eclipse.jface.text;bundle-version="3.8.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.5",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
  org.eclipse.ui.workbench.texteditor;bundle-version="3.8.0",
- org.eclipse.core.expressions;bundle-version="3.4.400",
- org.netxms.ui.base;bundle-version="2.1.2"
+ org.eclipse.core.expressions;bundle-version="3.4.400"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.7
 Bundle-ActivationPolicy: lazy
 Bundle-ClassPath: .
index cd68f1e..b83758e 100644 (file)
@@ -2,13 +2,14 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Event Management Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.eventmanager;singleton:=true
-Bundle-Version: 2.0.1
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.eventmanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.ui;bundle-version="3.8.2",
  org.eclipse.core.runtime;bundle-version="3.8.0",
  org.netxms.ui.eclipse.console;bundle-version="2.0.5",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.6"
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.7
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.eventmanager.dialogs,
index d1e98ac..cbbbb32 100644 (file)
@@ -1,9 +1,9 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <classpath>
-       <classpathentry exported="true" kind="lib" path="lib/simple-xml-2.6.4.jar"/>
        <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7"/>
        <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
        <classpathentry kind="src" path="plugin/src"/>
        <classpathentry kind="src" path="netxms-base/src/main/java"/>
+       <classpathentry exported="true" kind="lib" path="lib/simple-xml-2.7.1.jar"/>
        <classpathentry kind="output" path="bin"/>
 </classpath>
index 15ba20e..40cb263 100644 (file)
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NetXMS Base Library
 Bundle-SymbolicName: org.netxms.ui.base;singleton:=true
-Bundle-Version: 2.1.2
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.base.Activator
 Bundle-Vendor: Raden Solutions
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0"
diff --git a/webui/webapp/ActionManager/.settings/org.eclipse.jdt.core.prefs b/webui/webapp/ActionManager/.settings/org.eclipse.jdt.core.prefs
new file mode 100644 (file)
index 0000000..a698e59
--- /dev/null
@@ -0,0 +1,12 @@
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.8
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.source=1.8
index 64f753d..4257bc1 100644 (file)
@@ -2,14 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: org.netxms.ui.eclipse.actionmanager
 Bundle-SymbolicName: org.netxms.ui.eclipse.actionmanager;singleton:=true
-Bundle-Version: 2.0.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.actionmanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.1",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.0",
- org.netxms.webui.core;bundle-version="2.0.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.base;bundle-version="2.2.0"
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.actionmanager.dialogs,
  org.netxms.ui.eclipse.actionmanager.views.helpers
index d3dd752..e73341c 100644 (file)
@@ -84,7 +84,7 @@ public class ActionSelectionDialog extends Dialog
          }
       });
       
-      NXCSession session = (NXCSession)ConsoleSharedData.getSession();
+      final NXCSession session = ConsoleSharedData.getSession();
       new ConsoleJob("Get server actions", null, Activator.PLUGIN_ID, null) {
          @Override
          protected void runInternal(IProgressMonitor monitor) throws Exception
index fdcac0e..88c6640 100644 (file)
@@ -2,14 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: Agent Management Plug-In for NXMC
 Bundle-SymbolicName: org.netxms.ui.eclipse.agentmanager;singleton:=true
-Bundle-Version: 2.1.2
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.agentmanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.1",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui.forms;bundle-version="2.3.1",
  org.eclipse.core.runtime;bundle-version="3.12.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.5",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
  org.netxms.webui.core;bundle-version="2.1.5",
  org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.1",
  org.netxms.ui.eclipse.nxsl;bundle-version="2.0.7",
diff --git a/webui/webapp/AlarmViewer/.settings/org.eclipse.jdt.core.prefs b/webui/webapp/AlarmViewer/.settings/org.eclipse.jdt.core.prefs
new file mode 100644 (file)
index 0000000..a698e59
--- /dev/null
@@ -0,0 +1,12 @@
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.methodParameters=do not generate
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
+org.eclipse.jdt.core.compiler.compliance=1.8
+org.eclipse.jdt.core.compiler.debug.lineNumber=generate
+org.eclipse.jdt.core.compiler.debug.localVariable=generate
+org.eclipse.jdt.core.compiler.debug.sourceFile=generate
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.source=1.8
index 2efd8b8..00a0514 100644 (file)
@@ -2,18 +2,19 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Alarm Viewer Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.alarmviewer;singleton:=true
-Bundle-Version: 2.1.3
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.alarmviewer.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="3.1.0",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui.forms;bundle-version="3.1.0",
  org.eclipse.core.expressions;bundle-version="3.5.100",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.3",
- org.netxms.webui.core;bundle-version="2.1.1",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objectview;bundle-version="2.1.0",
  org.netxms.ui.eclipse.datacollection;bundle-version="2.1.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
 Bundle-ActivationPolicy: lazy
 Bundle-ClassPath: .
 Export-Package: org.netxms.ui.eclipse.alarmviewer.actions,
index 896f30c..9d66ee4 100644 (file)
@@ -36,6 +36,9 @@ import org.netxms.ui.eclipse.jobs.ConsoleJob;
 import org.netxms.ui.eclipse.logviewer.views.LogViewer;
 import org.netxms.ui.eclipse.tools.MessageDialogHelper;
 
+/**
+ * Alarm log viewer
+ */
 public class AlarmLogViewer extends LogViewer
 {
    public static final String ID = "org.netxms.ui.eclipse.alarmviewer.views.alarm_log_viewer"; //$NON-NLS-1$
index 1fc120e..e341df7 100644 (file)
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Charts Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.charts;singleton:=true
-Bundle-Version: 2.1.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.charts.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="3.1.0",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.5",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
  org.netxms.webui.core;bundle-version="2.1.5",
  org.eclipse.birt.chart.engine;bundle-version="4.6.0",
  org.eclipse.birt.chart.device.extension;bundle-version="4.6.0",
index b75e396..2a43f7e 100644 (file)
@@ -2,15 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NetXMS WebUI Core
 Bundle-SymbolicName: org.netxms.webui.core; singleton:=true
-Bundle-Version: 2.1.5
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.console.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.12.0",
  org.eclipse.rap.ui;bundle-version="3.1.0",
  org.eclipse.rap.ui.forms;bundle-version="3.1.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.5",
  org.eclipse.core.expressions;bundle-version="3.5.100",
- org.netxms.ui.base;bundle-version="2.1.2"
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.7
 Bundle-ActivationPolicy: lazy
 Import-Package: javax.servlet;version="2.5.0",
index 1ea33dd..6ddd9e7 100644 (file)
@@ -2,15 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Dashboard
 Bundle-SymbolicName: org.netxms.ui.eclipse.dashboard;singleton:=true
-Bundle-Version: 2.1.2
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.dashboard.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="3.1.0",
  org.eclipse.core.runtime;bundle-version="3.12.0",
  org.eclipse.core.expressions;bundle-version="3.5.100",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.4",
- org.netxms.webui.core;bundle-version="2.1.1",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.1",
  org.netxms.ui.eclipse.charts;bundle-version="2.0.5",
  org.netxms.ui.eclipse.osm;bundle-version="2.0.8",
index 13e7fa9..db34b4e 100644 (file)
@@ -2,15 +2,16 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: Data Collection Management Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.datacollection;singleton:=true
-Bundle-Version: 2.1.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.datacollection.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.1",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui.forms;bundle-version="2.3.1",
  org.eclipse.core.expressions;bundle-version="3.4.600",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.0",
- org.netxms.webui.core;bundle-version="2.1.0",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.0",
  org.netxms.ui.eclipse.eventmanager;bundle-version="2.0.1",
  org.netxms.ui.eclipse.snmp;bundle-version="2.0.0",
index ea9fa88..5f6986a 100644 (file)
@@ -2,17 +2,18 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NetXMS Event Processing Policy Editor
 Bundle-SymbolicName: org.netxms.ui.eclipse.epp;singleton:=true
-Bundle-Version: 2.0.4
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.epp.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.1",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.core.runtime;bundle-version="3.8.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.4",
- org.netxms.webui.core;bundle-version="2.0.4",
- org.netxms.ui.eclipse.eventmanager;bundle-version="2.0.0",
- org.netxms.ui.eclipse.nxsl;bundle-version="2.0.0",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.0.3"
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.eventmanager;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.nxsl;bundle-version="2.0.7",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
+ org.netxms.ui.base;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.epp.dialogs,
index 0dc2f1e..19f4a27 100644 (file)
@@ -2,12 +2,13 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Event Management Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.eventmanager;singleton:=true
-Bundle-Version: 2.0.1
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.eventmanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.6",
- org.netxms.webui.core;bundle-version="2.0.5"
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.eventmanager.dialogs,
index d59d88d..9efee7c 100644 (file)
@@ -2,15 +2,16 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NetXMS FileManager
 Bundle-SymbolicName: org.netxms.ui.eclipse.filemanager;singleton:=true
-Bundle-Version: 2.1.1
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.filemanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui;bundle-version="2.3.1",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.0",
- org.netxms.webui.core;bundle-version="2.1.0",
- org.eclipse.rap.filedialog;bundle-version="3.1.0"
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.eclipse.rap.filedialog;bundle-version="3.1.0",
+ org.netxms.ui.base;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.filemanager.views,
index bc37976..5aeb254 100644 (file)
@@ -2,15 +2,16 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Image Library Plugin
 Bundle-SymbolicName: org.netxms.ui.eclipse.imagelibrary;singleton:=true
-Bundle-Version: 2.0.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.imagelibrary.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.1",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.netxms.nebula.widgets.gallery;bundle-version="0.5.3",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.0",
- org.netxms.webui.core;bundle-version="2.0.0",
- org.eclipse.rap.filedialog;bundle-version="3.1.0"
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.eclipse.rap.filedialog;bundle-version="3.1.0",
+ org.netxms.ui.base;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.imagelibrary,
index c387445..aa0bb7e 100644 (file)
@@ -2,14 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Network Maps Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.networkmaps;singleton:=true
-Bundle-Version: 2.1.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.networkmaps.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="3.1.0",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.core.runtime;bundle-version="3.12.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.3",
- org.netxms.webui.core;bundle-version="2.1.1",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.1",
  org.netxms.ui.eclipse.imagelibrary;bundle-version="2.0.0",
  org.netxms.ui.eclipse.osm;bundle-version="2.0.8",
@@ -17,10 +18,10 @@ Require-Bundle: org.eclipse.rap.ui;bundle-version="3.1.0",
  org.netxms.gef4.zest.core;bundle-version="2.0.6",
  org.netxms.gef4.zest.jface;bundle-version="2.0.6",
  org.netxms.rap.draw2d;bundle-version="1.5.2",
- org.netxms.ui.eclipse.charts;bundle-version="2.0.5",
+ org.netxms.ui.eclipse.charts;bundle-version="2.2.0",
  org.netxms.ui.eclipse.nxsl;bundle-version="2.0.7",
- org.netxms.ui.eclipse.objectview;bundle-version="2.1.0",
- org.netxms.ui.eclipse.datacollection;bundle-version="2.1.0"
+ org.netxms.ui.eclipse.objectview;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.datacollection;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.networkmaps.algorithms,
index 204d287..e6df745 100644 (file)
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Open Street Maps Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.osm;singleton:=true
-Bundle-Version: 2.0.8
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.osm.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.2",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.9",
- org.netxms.webui.core;bundle-version="2.0.9",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.0.7",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
  org.netxms.rap.draw2d.compatibility;bundle-version="1.5.2"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
index 63e6bf5..4e253b0 100644 (file)
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Object Browser Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.objectbrowser;singleton:=true
-Bundle-Version: 2.1.1
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.objectbrowser.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="3.1.0",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.4",
- org.netxms.webui.core;bundle-version="2.1.1",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
  org.eclipse.core.expressions;bundle-version="3.5.100"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
index f7f69df..1f887ac 100644 (file)
@@ -2,14 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Basic Object Management Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.objectmanager;singleton:=true
-Bundle-Version: 2.1.4
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.objectmanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.0",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui.forms;bundle-version="2.3.1",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.5",
- org.netxms.webui.core;bundle-version="2.1.5",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.1",
  org.netxms.ui.eclipse.usermanager;bundle-version="2.0.8",
  org.netxms.ui.eclipse.nxsl;bundle-version="2.0.7",
index c233007..25a18ef 100644 (file)
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Object Viewer Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.objectview;singleton:=true
-Bundle-Version: 2.1.1
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.objectview.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.netxms.ui.eclipse.charts;bundle-version="2.0.4",
  org.eclipse.rap.ui;bundle-version="2.3.2",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.webui.core;bundle-version="2.1.1",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.2",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objecttools;bundle-version="2.1.0",
  org.netxms.ui.eclipse.imagelibrary;bundle-version="2.0.0",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.0",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
  org.eclipse.rap.ui.forms;bundle-version="3.1.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
index 6f589cc..5669423 100644 (file)
@@ -2,17 +2,18 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: Performance View Plug-in for NXMC
 Bundle-SymbolicName: org.netxms.ui.eclipse.perfview;singleton:=true
-Bundle-Version: 2.0.8
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.perfview.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.2",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.core.runtime;bundle-version="3.9.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.10",
- org.netxms.webui.core;bundle-version="2.0.10",
- org.netxms.ui.eclipse.charts;bundle-version="2.0.5",
- org.netxms.ui.eclipse.objectview;bundle-version="2.0.7",
- org.netxms.ui.eclipse.datacollection;bundle-version="2.0.5",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.charts;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.objectview;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.datacollection;bundle-version="2.2.0",
  org.netxms.ui.eclipse.usermanager;bundle-version="2.0.8",
  org.eclipse.core.expressions;bundle-version="3.4.400"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
index e3403a3..ae9107a 100644 (file)
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMS Policy Manager Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.policymanager;singleton:=true
-Bundle-Version: 2.0.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.policymanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
  org.eclipse.rap.ui;bundle-version="2.3.1",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.0",
- org.netxms.webui.core;bundle-version="2.0.0",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.0.0",
- org.netxms.ui.eclipse.agentmanager,
- org.netxms.ui.eclipse.serverconfig
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.agentmanager;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.serverconfig;bundle-version="2.1.0",
+ org.netxms.ui.base;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
index f71cc0b..e6b5ac1 100644 (file)
@@ -2,18 +2,19 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Reporter Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.reporter;singleton:=true
-Bundle-Version: 2.0.2
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.reporter.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
  org.eclipse.rap.ui;bundle-version="2.3.2",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui.forms;bundle-version="2.3.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.6",
- org.netxms.webui.core;bundle-version="2.0.5",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.0.3",
- org.netxms.ui.eclipse.filemanager;bundle-version="2.0.5",
- org.netxms.ui.eclipse.usermanager;bundle-version="2.0.4",
- org.netxms.ui.eclipse.eventmanager;bundle-version="2.0.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.filemanager;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.usermanager;bundle-version="2.0.8",
+ org.netxms.ui.eclipse.eventmanager;bundle-version="2.2.0"
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
 Bundle-ActivationPolicy: lazy
index 11f0789..a00699f 100644 (file)
@@ -2,24 +2,25 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Server Configuration Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.serverconfig;singleton:=true
-Bundle-Version: 2.1.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.serverconfig.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
  org.eclipse.rap.ui;bundle-version="2.3.1",
  org.netxms.ui.base;bundle-version="2.1.2",
  org.eclipse.rap.ui.forms;bundle-version="2.3.1",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.1.1",
- org.netxms.webui.core;bundle-version="2.1.1",
- org.netxms.ui.eclipse.filemanager;bundle-version="2.1.0",
- org.netxms.ui.eclipse.eventmanager;bundle-version="2.0.1",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.1.0",
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.filemanager;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.eventmanager;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
  org.netxms.ui.eclipse.nxsl;bundle-version="2.0.7",
- org.netxms.ui.eclipse.epp;bundle-version="2.0.4",
+ org.netxms.ui.eclipse.epp;bundle-version="2.2.0",
  org.netxms.ui.eclipse.objecttools;bundle-version="2.1.0",
- org.netxms.ui.eclipse.datacollection;bundle-version="2.1.0",
+ org.netxms.ui.eclipse.datacollection;bundle-version="2.2.0",
  org.eclipse.rap.filedialog;bundle-version="3.1.0",
- org.netxms.ui.eclipse.actionmanager;bundle-version="2.0.0"
+ org.netxms.ui.eclipse.actionmanager;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
 Export-Package: org.netxms.ui.eclipse.serverconfig.widgets,
index e3d25fe..75111fd 100644 (file)
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Server Job Manager Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.serverjobmanager;singleton:=true
-Bundle-Version: 2.0.0
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.serverjobmanager.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.rap.ui;bundle-version="2.3.1",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.0",
- org.netxms.webui.core;bundle-version="2.0.0"
+ org.netxms.ui.base;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.webui.core;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy
index db5b816..407bf65 100644 (file)
@@ -2,15 +2,15 @@ Manifest-Version: 1.0
 Bundle-ManifestVersion: 2
 Bundle-Name: NXMC Topology Plug-in
 Bundle-SymbolicName: org.netxms.ui.eclipse.topology;singleton:=true
-Bundle-Version: 2.0.3
+Bundle-Version: 2.2.0
 Bundle-Activator: org.netxms.ui.eclipse.topology.Activator
 Bundle-Vendor: netxms.org
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.9.0",
- org.netxms.ui.eclipse.objectview;bundle-version="2.0.1",
+ org.netxms.ui.eclipse.objectview;bundle-version="2.2.0",
  org.eclipse.rap.ui;bundle-version="2.3.0",
- org.netxms.ui.base;bundle-version="2.1.2",
- org.netxms.webui.core;bundle-version="2.0.1",
- org.netxms.ui.eclipse.objectbrowser;bundle-version="2.0.0",
- org.netxms.ui.eclipse.clientlibrary;bundle-version="2.0.1"
+ org.netxms.webui.core;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.objectbrowser;bundle-version="2.2.0",
+ org.netxms.ui.eclipse.clientlibrary;bundle-version="2.2.0",
+ org.netxms.ui.base;bundle-version="2.2.0"
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-ActivationPolicy: lazy